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Introduction 
 
Congratulations on using one of the most flexible and powerful graphical development tools in 
the world, OpenInsight from Revelation Software. 
 
This Quick Start guide is designed to let you jump right into application development. We 
recommend that you follow the Getting Started PDF that came with this package, but this quick 
start covers many of the same topics, just not in any great detail. 
 
By following this document, you should be able to: 

1. Attach your D3 data to OpenInsight 
2. Convert data dictionaries from a D3 file 
3. Create a data entry form for that data file 
4. Create a Multiple Document Interface (MDI) frame with menu 
5. Hook your data entry form up to the MDI frame 
6. Create a popup for searching 
7. Hook that popup up to your data entry form 
8. Create a report against your data file 
9. Hook up your report to the MDI Frame 

 
So, in less than ten steps, you will have created an entire application. 
 
The Getting Started PDF will give more details and background about concepts and terms that 
you should become familiar with as you develop more with OpenInsight. You can also check out 
our website, www.Revelation.com, where we have a free, online threaded discussion where you 
can ask questions, or search on existing issues. 
 
Thanks again for trying out such a great product, and good luck! 
 
TigerLogic and D3 are trademarks of TigerLogic Corporation. 
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Starting OpenInsight 
 
I. Starting OpenInsight 
 

1. Launch OpenInsight. 
2. Start, Programs, OpenInsight Development Suite, OpenInsight Sysprog.   

 

 
 

3. The Application Manager window for the SYSPROG application will be displayed as 
shown below. 
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II. Opening an Existing Application 
 

4. Choose Open Application from the File menu.  The Open Application dialog box will be 
displayed. 

 

 
 

5. Choose the SYSPROG application from the Name list box. 
6. Click in the User Name edit line and type SYSPROG. 
7. Click the OK button the open the SYSPROG application. 

 
Note:   To open any application provided with OpenInsight, enter the Application Name 

in the User Name edit line.  Passwords are not required for sample applications. 
 
The Application Manager window for the SYSPROG application will be displayed, as 
shown below. 
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III. Creating a New Application 
 

8. Choose Application,New Application from the File menu to create a new application.  
The New Application dialog box is displayed. 

 

 
 

The Application Name and Author User Name are the only required items in this dialog 
box. 

 
9. Click in the Name edit line and type MVDEMO. (Spaces are not allowed in an 

Application Name or User Name.) 
 

10. Click in the User Name edit line and type MVDEMO. 
 

Note:   The Inheritance drop down indicates <Default Inheritance>.  This means that this 
newly created application inherits the components of the base application, 
SYSPROG, mentioned above. 
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11. Click the OK button to create the new MVDEMO application. 
The Application Manager window for the MVDEMO application will be displayed, as 
shown below. 
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Connecting To Your D3 Database  
 
I. Requirements 
 
For the purposes of this example we will be using TigerLogic’s D3 version 9.0, and using the 
MVDEMO sample database. We will presume that the D3 system is installed on the local 
machine, using the default settings provided by TigerLogic.  The TIGRMVSP.dll supplied by 
TigerLogic must be copied to your OpenInsight directory .  This file can be found in 
C:\Program Files (x86)\TigerLogic\D3\D3Programs\MVSP\MVSPNetAPI.zip 
 
II. Making the connection 
 

1. The easiest way to define a new D3 connection for the D3 Connector is to use the D3 
Connection Wizard.  It can be found in OpenInsight versions 9.2 and greater, in the 
Database Manager. 
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2. From the Database Manager choose Utilities, Other MV Tables, D3 Connection Wizard. 
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3. When the Wizard is first started, the user is presented with a Welcome screen. Clicking 
on the ‘Next’ button brings up the next panel which prompts the user for the Connection 
Name.  
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4. The name of the connection is used by OpenInsight to attach to the data. Below you can 
see that we have named this connection MVDEMO. 
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5. Clicking on the ‘Next’ button brings up a panel that prompts for the location of the 
Shadow Dictionary location. Shadow Dictionaries are OpenInsight versions of the 
column definitions that define the D3 table. OpenInsight does not want to affect the 
column definitions on the D3 data source, so a local copy is made.  There are a number of 
advantages to this, including formatting for OpenInsight reports. 

 
The Wizard offers a default folder location where the shadow dictionaries will be created.  
If a full path is not specified a directory will be created within your OpenInsight folder. 
We will accept this default, and then click on the ‘Next’ button. 
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6. The next panel displayed is where the IP address of the D3 server is entered.  
 

The IP Address lets OpenInsight know the address of the server, either on the local 
machine, the local network, or the world wide web.  The wizard defaults the IP Address 
to 127.0.0.1, which is the local host machine. You should either change it to the address 
given to you by the System Administrator. 
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7. Clicking on the ‘Next’ button brings up the Server Port panel.  The Server Port number is 
port number on the server that OpenInsight will connect through. D3 version 9.0 supports 
port number 9000, so that is what OpenInsight defaults to. You can either accept the 
default, or change it to the Port Number given to you by the System Administrator. 
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8. Clicking on the ‘Next’ button brings up the Account/Directory panel.  The 
Account/Directory Panel is where the user enters the name of the account where the D3 
files are stored, or the directory that holds the D3 files the user wants to work with.    

 
For the purposes of this exercise we will use the MVDEMO account. Enter that name and 
click on the ‘Next’ button. 
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9. This will bring up the Logon Credentials form. The Logon Credentials screen is where 
the user enters the information needed for OpenInsight to connect to the D3 Server. 

 
The Logon ID is a username accepted on the server 

 
The Password is the password required by the Logon ID. 

 
The Logon Procedure is the name of a procedure that will run on the D3 server when 
OpenInsight connects using the Logon ID specified. 

 
None of these fields are required. 
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10. For the purposes of this exercise, enter a Login ID of DM and click on the ‘Next’ button.  
Neither a Password nor Logon Procedure is needed. 
 

  
 

11. Clicking on the ‘Next’ button brings up the Completion panel. Click on the ‘Finish’ 
button to complete the Wizard. The D3 Connection is now ready for use. 
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12. The Database Manager will now display the D3 Volume that we named MVDEMO.  All 
the tables (files) within that volume are displayed. 
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13. Upon completion, the Connection Wizard creates an entry in the SYSPTRS or System 
Pointers table. As such, the record in the SYSPTRS table can be viewed in the System 
Editor. 
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III. Displaying and editing your data dictionaries 
 

14. Select Table Builder from the Application Tools menu or press the Table Builder button 

. 
 

 
 
 
  



OpenInsight for D3 Quick Start Guide  Page 22 of 61 

Copyright © 2010, Revelation Software. All Rights Reserved. 

 
15. Select File, Open from the Table Builder dialog box. 
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16. Your D3 tables will display.  Select a table to view the converted dictionaries.  
OpenInsight for D3 will convert your D3 dictionaries to the OpenInsight format and store 
them in the Shadow Dictionaries location you specified in the D3 Connector Wizard 
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17. Once a table is selected, the converted dictionaries will be displayed in the Table Builder.  
Double click on any column to view the dictionary details. 
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18. Change the Len properties on each dictionary column to match as shown below: 
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19. Below are the converted dictionaries of the ORDERS table.  Correlatives and conversions 
have been converted to Calculated Columns.  Double click on a calculated column to 
view its dictionary properties. 
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IV. Editing a Calculated Column 
 

20. Double-click in the row containing SHIPADDRESS of the Calculated Columns edit table 
at the bottom of the Table Builder window.  This will display the Calculated Column 
Attributes window. 

 
Note:  @ANS is a system variable used to store the value of a calculated column. 
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Working with Forms 
 
I. Creating a Data Entry Form 
 

1. Open the Form Designer.  Click on Form Designer from the Application Tools menu or 

press the From Designer button . 
2. Choose New Form from the File menu in the Form Designer to display the New Form 

dialog box. 
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3. Select OpenInsight Tables from the Data Source drop-down list.  A list of native tables is 
displayed in the left list box. 

4. Select the OpenInsight table from the list in the left list box (by double-clicking the 
name).  Choose CUSTOMERS 

5. The columns from the selected table are displayed in the Fields/Columns list box.  
6. Select columns from the Fields/Columns list box to use in creating the OpenInsight form. 

To select a column, double-click on the column name in the Fields/Columns list box or 
select the column and click the Add button.  The selected columns are displayed in the 
selected columns edit table. The order in which columns are selected sets the tab order for 
the controls in the OpenInsight form being created.  Select all the fields. 

7. The default control type for columns is an edit line. The edit table control is the default 
control type for a multi-value column.  If you want to specify another control type, select 
the appropriate column row in the selected columns edit table and double-click to display 
a list of control types.  Double-click the required control type in the control type list for 
the specified column.  The new control type is indicated in the selected columns edit 
table. 

8. If you want to remove a column from the selected columns edit table, select the column 
row and click the Remove button.  The row is deleted from the edit table and therefore 
not displayed on the OpenInsight form. 

9. When all columns have been selected and the required controls specified, click the OK 
button to create the default OpenInsight form.   The form should resemble the following: 
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10. Save the form by choosing Save from the Form Designer File menu.  The Save As dialog 
box will be displayed. 

 

 
 

11. Type CUSTOMERS in the Form Name field and click the OK button. 
 

II. Adding/Displaying Data to/from the Table  
 
1. Choose Preferences from the Form Designer Tools menu and verify that Actual data 

tables is selected in the Testrun with: group then click the OK button.  This assures that 
the data you create is saved in the CUSTOMERS table. 
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2. Click the TEST RUN button  or choose Test Run from the Form Designer File menu. 
 

3. Type an initial value (1 – 50) for the Customerid then tab off the field.  The form will 
display the customer information.   

 
4. You can also enter a new customer record by selecting a Customerid greater than 50. 

 

 
 

5. Press control + S or choose Save Row from the File menu to save this record.  The record 
is saved, the form is cleared.  After adding or displaying the last record, choose Close 
from the File menu to exit the form.  This will return you to the Form Designer. 
 

III. Creating an MDI Frame  
 

Multiple Document Interface (MDI) windows are child windows or OpenInsight forms that 
belong to a parent frame and are displayed in the window client area.  The MDI Frame is the 
main window and normally contains a menu, a client area and a status line.  The MDI Frame 
controls all of the child windows.  The MDI children are the OpenInsight forms that appear 
within the client area of the MDI frame. 

 
 

1. Select New MDI frame from the Form designer File menu to display the Select Style 
Sheet dialog box which lists the existing OpenInsight forms in the current application. 

 

 
 

2. Click the OK button to exit the Select Style Sheet dialog box without selecting a style 
sheet.  
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An MDI frame with an MDI client window is displayed.  The MDI client window is part 
of the frame window and cannot be deleted or copied.  MDI child windows are confined 
to the MDI client area.  The text “MDI Client Window” is visible only during 
OpenInsight form design so that you can distinguish the MDI client area from other 
controls.  The Client Window should display as follows: 

 
 

The MDI Client Window can be resized. 
 
IV. Creating an MDI Child 

MDI Child windows are those that reside within the MDI client area.  MDI Child windows 
can be any OpenInsight form created for the current application.  MDI Child windows are 
often created prior to creating the MDI frame.  A feature of MDI child windows is that they 
do not contain menus.  Menu functionality is provided by the frame. 

 
An MDI child is executed from the MDI frame with the BASIC+ function 
START_MDICHILD. 

 
1. Choose Design from the Menu menu.  The Menu Builder dialog box is displayed. 
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The first menu item is highlighted. 
 

2. Select Insert item after selection from the Edit menu. 
3. Type ‘&Customers’ in the Popup/item text field.  The Popup/Item ID: field is 

automatically populated. 
4. Choose Exit/Update from the File menu. 
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5. Choose QuickEvents from the Menu menu.  The QuickEvents dialog box is displayed. 

 
 

6. Choose FILE.CUSTOMERS from the Event drop down list. 
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7. Choose Start MDI child window from the QuickEvent Options: list.  The QuickEvent 

dialog box will be populated with default settings for the Start_MDIChild function. 
 

 
 
 

8. On the Parameters: change ChildName to ‘CONTACTS’ and CreateParam to null (‘’).  
Include the single quotes. 

 
9. Press the Accept button.  This will place a <q> next to FILE.CONTACTS in the Event 

field. 
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10. Press the Close button.  This will return you to the MDI Frame.  
 

11. Select Save from the File menu.  Enter MVDEMO_MDI for the name of the form. 
 

12. Test run the form.  Choose Test Run from the File menu in the Form Designer.  The 
following will display: 
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13. Choose Customers from the File menu.  The following screen will display: 

 

 
 

Your application now contains MDI capability. 
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Working with Popups 
 
I. Creating a Popup 
 

1. Launch the User Interface Workspace by clicking on User Interface Workspace from the 

Application Tools menu or press the UI Workspace button . 
 

 
 

2. Choose New from the File menu; choose Popup from the New Entity dialog box to 
display the Popup Designer below. 
 

3. Type: Customers in the title edit line on the General tab.  This is displayed in the title bar 
of the popup.  Review the other options on this tab and accept the defaults, then click the 
Source tab. 
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4. Click the Source tab where you specify a data source used to populate the Popup.  
Review all options and choose Select Rows from Table. 

 

 
 

5. Click the Selection tab (which is dependent on the Source you selected). Regardless of 
the appearance of the Selection page, the process to be performed is that of selecting the 
specific data to be displayed in the Popup. The definition of a selection formula may be 
required. 
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Select CUSTOMERS from the Table drop down.  Choose the fields you want displayed 
from the Available list and click the right arrow button.  This will place the fields 
selected in the selected list. 
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6. Click the Layout tab to describe how you want the Popup to look including column 
headings and alignment, width, etc.  This is pre-populated with settings from the data 
dictionary. 
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7. Click the Value tab where you specify what information you want the Popup to return, 
and specify the number of selections that can be made in the Popup. 
 

 
  



OpenInsight for D3 Quick Start Guide  Page 45 of 61 

Copyright © 2010, Revelation Software. All Rights Reserved. 

8. Click the Options tab where a number of miscellaneous characteristics of the Popup are 
specified. 
 
 

 
  



OpenInsight for D3 Quick Start Guide  Page 46 of 61 

Copyright © 2010, Revelation Software. All Rights Reserved. 

9. Save the Popup, and then test it by choosing File, Test Run. 
 

 
 
II. Adding Popup Functionality to a Window 
 

The most common use of a Popup is to provide users with a list of choices during data entry.  
The following procedure will demonstrate how to add a button to an existing form and the 
Event Handler necessary to execute the Popup and place the results within a data field. 

 
1. Open the Form Designer. 
2. Select Open from the File menu.  Choose the CUSTOMERS form. 
3. From the Controls tool bar select a button by clicking on the OK button icon, in the upper 

right corner 
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4. Place the control on the form by moving the mouse cursor to a location on the form 
where you want to place the control.  The mouse cursor changes to the control’s icon 
with a + appearing to the left and above the icon as soon as the mouse cursor enters the 
form.  The + is used to help position the control.  Click the left mouse button where you 
want to place the control.  The control is displayed in the form in the selected state (with 
handles visible).   

 
 

5. Double-click on the button.  The Push Button Properties window will appear.  Change the 
Name of the control to “BTN_CHOOSE_CUSTOMER” and the Text that is displayed on 
the control to “Choose Customer”.  
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6. Click on the Events button to display the QuickEvent dialog box. 
 

 
 

7. The CLICK event will be chosen by default. 
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8. Click on the Scripts button.  This will launch the Event Editor.  In the Editor type the 
following code: 
 
declare subroutine Set_Property, Send_Event 
declare function Popup 
 
retval = Popup(@window,"","CUSTOMERS") 
Set_Property(@window:".CUSTOMERID",”DEFPROP”,retval) 
Send_Event(@window:".CUSTOMERID","LOSTFOCUS") 

 
9. Select Check Syntax from the File menu.  Any errors will be displayed at the bottom of 

the Event Editor window.  If the syntax is correct the status line will display “The syntax 
is correct”. 

 

 
 

This will cause a popup to display when the Choose Customers button is clicked.  The 
user may choose a Customer.  The value chosen will be placed into the CUSTOMERID 
control on the Customers form.  When the CUSTOMERID field loses focus a read of the 
CUSTOMERID placed into the field will occur. 

 
10. Select Exit/Update from the File menu.  This will save the code and return to QuickEvent 

dialog box. 
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11. Press the Apply button.  This will place a <s> next to CLICK in the Event field. 
 
12. Press Close.  This will return you to the Push Button Properties window.  Select OK on 

the properties window.  This will return you to form. 

 
 

13. Choose Save from the File menu. 
 

14. To test run the MDI Frame, access the Contacts form from the File menu and click on the 
Choose Contact button.  
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Working with Reports 
 
I. Report Builder+ 
 

The OpenInsight Report Builder+ is a tool used to create R/List type reports.  Using the 
Report Builder+ the developer or end-user can create columnar reports on any attached table 
with a minimum of effort. 
 
 

 
II Creating a Report 

In this procedure you’ll create a columnar report based on the CONTACTS table. 
Exit all tools and return to the Application Manager. 
 
1. Click the Report Builder from the Application Tools menu or press the Report Builder 

button . 
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2. Choose New Report from the File menu. The Select Table dialog box is displayed.  Select 
the CUSTOMERS table. 

 

 
 
3. Click the OK button. The Font dialog box is displayed followed by the Select Columns 

dialog box. 
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4. From the Available Columns list box, select the following fields by clicking on each 
specified field and clicking the > button. 
 
CUSTOMERID 
ORGANIZATIONNAME 
CONTACTNAME 
PHONENUMBER 
STATE 

 
5. The selected field names display in the Selected Columns list. 
 

 
 

Note: If the Selected Columns are not in the order in which you want them to appear on 
the report, click the Reorder button to display the Reorder Dialog box. 
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6. The screen will now resemble the following: 
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7. To save the report, choose Save from the File menu.  Type CUSTOMERS as the report 
name and click the OK button. 
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8. Choose Preview from the File menu.  The following report will be displayed. 
 

 
 
9. Click the Close button on the Preview window. 
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Setting an Application Entry Point 
 
The application entry point is the first window that is displayed when the application is 
executed at runtime.  For our purposes this will be the MDIFrame MVDEMO_MDI.  The 
following steps will define the application entry point. 
 
1. Choose Application Properties from the Application Manager File menu to display the 

Application Properties dialog box shown below. 
 

 
 
 

2. Click the SETUP ENTRY POINT button (in the bottom left hand corner of the dialog 
box). The Setup Application Main Entry Point dialog box is displayed, as shown below. 
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3. Clear the No Application Entry Point check box. The window names in the Window 
Name list box become enabled. 

 
4. Select the form MVDEMO_MDI in the Window Name list box. 

 
5. Click the OK button to update the application Entry Point option and return to the 

Application Properties dialog box. Click the OK button to close this dialog. 
 

6. You will need to close and reopen OpenInsight to the MVDEMO application.  Now, 
choose Run Application from the File, Application Manager File menu. Your application 
will now launch. 
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7. Select the MVDEMO application and enter MVDEMO in the User Name edit line, then 
click the OK button to execute the MVDEMO APPLICATION. 

 
8. The MVDEMO_MDI window is displayed in runtime mode. 

 

 
 

Congratulations! You’ve successfully completed your first application using OpenInsight. 
And what you’ve learned here is just the beginning. You may continue by taking a look at the 
sample applications that are included with OpenInsight, or begin your own development 
project. Whatever your choice, we wish you continued success using OpenInsight. 
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